SyncEvolution 1.5.3

Maintenance release. syncevolution.org binaries are now getting
compiled for distros >= Ubuntu Xenial 16.04 LTS. Usage of deprecated
libraries (GNOME keyring) and APIs (SoupAsyncSession) was
replaced. libical v3 is supported.

The code now compiles more cleanly with recent compilers and depends
on C++11 support.